logo

System Requirements

We support and recommend the most recent versions of Microsoft Edge Chrome Firefox , and  Safari  (Mac Only). Versions older than one year, and discontinued versions are not supported.

Additional system requirements:

Beta versions or Developer builds are not recommended.

You may encounter unexpected bugs in beta and developer builds of our supported browsers.